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Symptom

  • From time to time, one or more lights on the Home Phone Terminal (eMTA) may go out or begin to flash.
  • Symptoms vary depending upon which light is off:
    • Battery Light Flashing:
      • If the Battery light is flashing, the battery is either low or is being charged (after installation or replacement). You can still use your telephone while the backup battery is charging.
    • Battery Light Off:
      • The backup battery may not be inserted correctly or is missing, phone service will not work in the event of a power failure if the backup battery is missing or not inserted correctly.
    • Power Light Flashing:
      • If the Power light begins to flash or is out, you may not have phone service because the eMTA is not receiving AC power.
    • Telephone Light(s) Flashing:
      • If the Telephone 1 and/or Telephone 2 light is/are flashing, you may experience no dial tone one or more phones is/are off the hook or there may be a wiring problem.

Cause

  • Battery power is low
  • Battery is charging
  • Battery is not inserted correctly
  • Battery missing
  • Battery is defective
  • There is a power failure
  • The eMTA is not receiving AC power
  • The phone line is in use
  • A phone is off the hook
  • Inside wiring issue

Resolution

The front of your Home Phone Terminal contains a series of LED indicators (lights) that indicate the status of various elements that provide your phone service. During normal operation, all of the lights on the Home Phone Terminal will remain on except for the Link LED and, if your Home Phone Terminal has one, the Battery 2 LED.

Confirm the light pattern on your Home Phone modem.

Battery Light Flashing:

  1. If there have been no recent power failures or the battery was not recently installed or replaced, please call Rogers at 1-866-889-5230.
    • A service visit will be booked at a time of your choosing.
  2. A technician will then come to your home and replace the battery.
    • The visit will typically take 5 to 10 minutes.

Battery Light Off:

  1. Check your Rogers Home Phone Terminal and ensure that a battery is present.
    • If there is no battery, call 1-866-889-5230.
      • A service visit will be booked at a time of your choosing.
      • A technician will then come to your home and install a battery.
        • The visit will typically take 5 to 10 minutes.
    • If there is a battery, remove it and then securely reinsert it (you should hear a click). For instructions on reseating your eMTA battery please choose from the following:
    • If the battery is properly seated, the light will begin flashing to indicate that it is charging.
  2. If the battery light still isn’t lit, call 1-866-889-5230.
    • A service visit will be booked at a time of your choosing.
  3. A technician will then come to your home and replace the battery.
    • The visit will typically take 5 to 10 minutes.

Power Light Flashing:

  1. Confirm that both ends of the AC power adapter are properly connected.
  2. If the AC power adapter is properly connected and the Power light is still out, contact Rogers Home Phone Technical Support at 1-888-764-3771.

Telephone Light(s) Flashing:

  1. Confirm that all of your phones are properly hung up.
  2. Reboot the eMTA. For instructions please see:
  3. If the light is still flashing and all phones are hung up, contact Rogers Home Phone Technical Support at 1-888-764-3771.