Symptom
- The touchpad is frozen on a particular screen.
- Widgets are non-responsive to touch.
- Physical buttons (Home button) are non-responsive.
Cause
- Loss of AC power
- Screen needs to be cleaned
- Backup battery drained due to power loss
Resolution
- Verify the touchpad is frozen by pressing the physical home button.
- Ensure AC power is on.
- If the power cord is disconnected, plug the touchpad back into AC power.
- Determine what actions led up to frozen touchpad.
- Did the touchpad freeze while attempting to arm/disarm?
- Can you still hear sounds from zone tripping?
- Attempt to reboot the touchpad by removing the battery from the touchpad and re-insert battery.
- If the issue still continues contact a Smart Home Monitoring Technical Support Consultant.