- Unable to load Rogers On Demand (ROD) or channel 100
Rogers On Demand Issues
Symptom
Cause
- Weak signal or one way signal which is unable to communicate with Rogers
- Network congestion or outage
- Hardware issue
Resolution
- Confirm that the coaxial cable is connected directly to the set-top box. If the cable is connected to a VCR, cable booster, cable surge protector, or personally installed cable splitter, disconnect the coaxial cable from the equipment and connect it to the Cable In port of the Rogers set-top box.
- Note: please do not disconnect any cable splitters or signal boosters that were installed by a Rogers technician as this may impact your other cable services.
- Reset the digital set-top box by unplugging the power cord for 20 seconds and reconnect.
- Once the set-top box is done loading, turn on the power and go to channel 100.
- If ROD is still not loading, please contact Technical Support for further assistance.